CONFIGURAÇÃO | REDE MPLS

by - 11:39 AM


Nesta seção iremos aprender como configurar uma rede MPLS do zero, com roteadores Cisco emulados através do Unified Networking Labs (UNL) . Lembro que também é possível realizar as configurações deste lab utilizando o GNS3.

Unified Networking Labs (UNL) 

GNS3

Topologia - Rede MPLS

Neste lab faremos a simulação de duas VPN's de empresas distintas, "Loja de Calçados" chamada de VP1 e "Farmácia" chamada de VP2, utilizando o Backbone de uma operadora de Telecom. Assim teremos uma visão que o tráfego destes clientes que passa por dentro da operadora são totalmente isolados. Neste laboratório, estou indo direto ao ponto, ou seja, "Configuração", mas para conhecimento da tecnologia  por completo, sugiro a leitura sobre o tema no site da Cisco através do link abaixo:


Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 12.2SR


Configurações dos roteadores do Backbone da Operadora de Telecom:


  Configurações PE1:

ip vrf VP1
 rd 65001:111
 route-target export 65001:1
 route-target import 65001:1
!
ip vrf VP2
 rd 65002:222
 route-target export 65002:2
 route-target import 65002:2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 200.10.10.2 255.255.255.252
 mpls ip
!
interface Serial1/0
 ip vrf forwarding VP1
 ip address 172.16.1.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!         
interface Serial1/1
 ip vrf forwarding VP2
 ip address 172.16.2.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 200.10.10.0 0.0.0.3 area 0
!
router bgp 65500
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 65500
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 next-hop-self
 !
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
  neighbor 2.2.2.2 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf VP1
  neighbor 172.16.1.2 remote-as 65001
  neighbor 172.16.1.2 update-source Serial1/0
  neighbor 172.16.1.2 activate
  neighbor 172.16.1.2 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf VP2
  neighbor 172.16.2.2 remote-as 65002
  neighbor 172.16.2.2 update-source Serial1/1
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 next-hop-self
 exit-address-family

 

Configurações PE2:

ip vrf VP1
 rd 65001:111
 route-target export 65001:1
 route-target import 65001:1
!
ip vrf VP2
 rd 65002:222
 route-target export 65002:2
 route-target import 65002:2
!
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!         
interface Ethernet0/0
 ip address 200.20.20.2 255.255.255.252
 mpls ip
!
interface Serial1/0
 ip vrf forwarding VP1
 ip address 172.16.3.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/1
 ip vrf forwarding VP2
 ip address 172.16.4.1 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 200.20.20.0 0.0.0.3 area 0
!
router bgp 65500
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 65500
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
  neighbor 1.1.1.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf VP1
  neighbor 172.16.3.2 remote-as 65001
  neighbor 172.16.3.2 update-source Serial1/0
  neighbor 172.16.3.2 activate
  neighbor 172.16.3.2 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf VP2
  neighbor 172.16.4.2 remote-as 65002
  neighbor 172.16.4.2 update-source Serial1/1
  neighbor 172.16.4.2 activate
  neighbor 172.16.4.2 next-hop-self
 exit-address-family



Configurações P:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
 ip address 200.10.10.1 255.255.255.252
 mpls ip
!
interface Ethernet0/1
 ip address 200.20.20.1 255.255.255.252
 mpls ip
!
router ospf 1
 network 3.3.3.3 0.0.0.0 area 0
 network 200.10.10.0 0.0.0.3 area 0
 network 200.20.20.0 0.0.0.3 area 0





Configurações dos roteadores do cliente Loja de Calçados VPN VP1:


Configurações AVP1

interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.252
 serial restart-delay 0
!
router bgp 65001
 bgp log-neighbor-changes
 network 172.16.1.0 mask 255.255.255.252
 network 192.168.1.0
 neighbor 172.16.1.1 remote-as 65500
 neighbor 172.16.1.1 allowas-in



Configurações BVP1

interface Loopback0
 ip address 192.168.2.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.3.2 255.255.255.252
 serial restart-delay 0
!
router bgp 65001
 bgp log-neighbor-changes
 network 172.16.3.0 mask 255.255.255.252
 network 192.168.2.0
 neighbor 172.16.3.1 remote-as 65500
 neighbor 172.16.3.1 allowas-in



Configurações dos roteadores do cliente Farmácia VPN VP2:


Configurações AVP2

interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.2.2 255.255.255.252
 serial restart-delay 0
!
router bgp 65002
 bgp log-neighbor-changes
 network 172.16.2.0 mask 255.255.255.252
 network 192.168.1.0
 neighbor 172.16.2.1 remote-as 65500
 neighbor 172.16.2.1 allowas-in


Configurações BVP2

interface Loopback0
 ip address 192.168.2.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.4.2 255.255.255.252
 serial restart-delay 0
!
router bgp 65002
 bgp log-neighbor-changes
 network 172.16.4.0 mask 255.255.255.252
 network 192.168.2.0
 neighbor 172.16.4.1 remote-as 65500
 neighbor 172.16.4.1 allowas-in



IOS utilizado: I86BI_LINUX-ADVENTERPRISEK9-M-15.2.3.bin


 E isso é tudo, Abraços!


Matheus Damacena!

You May Also Like

0 Comments